Slow reporting, emails, and letters
Incident Report for Bloomerang
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 02, 2018 - 12:30 EDT
Investigating
We are currently experiencing a significantly higher volume of reports. We are working on creating additional servers to relieve the load. Reports, letters, emails, and imports are currently affected.
Posted about 1 year ago. Aug 02, 2018 - 12:09 EDT
This incident affected: CRM.