Our Third Party email provider is experiencing outages that may cause delays in Bloomerang email delivery
Incident Report for Bloomerang
Resolved
https://status.sendgrid.com/

SendGrid is confident they have identified the issue and is monitoring performance as their systems recover. Mail sent out of Bloomerang should be delivered as expected.
Posted Jul 28, 2020 - 15:59 EDT
Update
https://status.sendgrid.com/

SendGrid is working to restore their full email functionality. Mail should now be sent and received as expected, but customers may still experience delays.
Posted Jul 28, 2020 - 14:44 EDT
Investigating
https://status.sendgrid.com/

We are working to get updates from Sendgrid, but until their system issues are resolved you may see delays in email delivery, including mass email, form notification emails, BCC to Bloomerang, and scheduled reports.
Posted Jul 28, 2020 - 13:27 EDT