Degraded Performance Across Application
Incident Report for Bloomerang
Resolved
Teams have continued monitoring (and testing) throughout the week; system performance issues experienced on Wed 8/30 and Thu 8/31 have been resolved. Upon completing maintenance on Wed 8/30 and Thu 8/31, we have seen significant improvement to application performance.
Posted Sep 05, 2023 - 17:49 EDT
Update
Our teams continue to monitor performance today to ensure that the changes implemented will mitigate and resolve possible degraded performance. We have thus far seen significant improvements with the maintenance performed over the past few days and will provide updates should we see this change or if further enhancements are required.
Posted Sep 01, 2023 - 12:32 EDT
Update
We continue to closely monitor system performance throughout the day. While the number of customers impacted is minimal, we have been implementing changes to our infrastructure to mitigate any intermittent slowness or degraded performance that any users may be experiencing. Our teams will continue to investigate potential improvements and will provide updates should we see changes in performance or impact.
Posted Aug 31, 2023 - 18:44 EDT
Update
Our team is continuing to monitor for possible performance degradation today. This is to monitor the performance of the changes we made during maintenance on 8/30/2023.
Posted Aug 31, 2023 - 10:45 EDT
Monitoring
We have completed all emergency maintenance planned for this evening. We've attempted multiple optimization techniques across our infrastructure and, as noted, some required application downtime to complete them (both at 9:15pm and 10:15pm EST). The teams will continue to monitor this evening and early in the morning. We'll provide updates from the research tomorrow morning and decide if further maintenance is required.
Posted Aug 30, 2023 - 22:58 EDT
Update
We will be undergoing emergency system maintenance starting at 9:15 PM and 10:15 PM EST to help address this issue. We will post an update as soon as maintenance is complete and systems are restored.
Posted Aug 30, 2023 - 21:11 EDT
Identified
Our team began an internal investigation of suspected performance degradation upon seeing a slow but steady increase in performance issues over the course of today, this investigation led us to report an incident at approximately 2:00 PM (EST). While investigating root cause we have also identified that a number of third parties were having issues throughout today which exacerbated the response time to this incident.

In response to the degraded performance issues impacting multiple functionalities across the platform today (8/30/2023), we are actively performing maintenance this afternoon with the goals to reduce the database load and increase functionality. This maintenance is not expected to cause downtime to the platform.

We apologize for any inconvenience that our users have experienced and will submit further updates as this maintenance is completed!
Posted Aug 30, 2023 - 18:12 EDT
Update
We are continuing to investigate this issue.
Posted Aug 30, 2023 - 17:22 EDT
Update
We are continuing to investigate the root cause of this issue. Thank you for your patience as we continue to review.
Posted Aug 30, 2023 - 15:32 EDT
Investigating
We’re currently experiencing degraded performance issues that may be impacting multiple functionalities. Our team is investigating the issue and is currently working to restore operations. We apologize for any inconvenience if users are affected. An update will be provided within 30 minutes.
Posted Aug 30, 2023 - 14:56 EDT
This incident affected: CRM.