Email Tracking Statistics have been temporarily disabled
Incident Report for Bloomerang
Resolved
The email tracking statistics functionality has been reenabled. Please be patient, it may take some time for the backlog of data to processed and available for viewing.
Posted Nov 29, 2022 - 21:57 EST
Investigating
Our Engineers have turned off the "tracking" tab at this time to improve performance. This feature will be back up an running as expected with tracking data later today. Before resending any scheduled emails please navigate to the "details" tab of your email and confirm the last sent date is not from today.
Posted Nov 29, 2022 - 12:58 EST
This incident affected: Email Tracking Statistics.