Partial service outage

Incident Report for Bloomerang

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 18:15 EST

Monitoring

We are no longer seeing reports of the "503" errors and we are monitoring results.
Posted Jan 20, 2026 - 16:45 EST

Investigating

We’re currently experiencing degraded performance issues with one or more of our listed components. Users may see a "503 Service Temporarily Unavailable" page when navigating the application. We apologize for any inconvenience.
Posted Jan 20, 2026 - 16:33 EST
This incident affected: Bloomerang CRM (CRM App - crm.bloomerang.co).