Degraded Performance
Incident Report for Bloomerang
Resolved
The fix implemented has resolved this issue and performance is restored.
Posted Jun 04, 2024 - 17:49 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2024 - 15:34 EDT
Update
We are continuing to investigate the root cause of reported slowness. Updates will be provided as more information becomes available.
Posted Jun 04, 2024 - 14:54 EDT
Investigating
We are currently investigating reports of degraded performance involving slowness while Logging in Bloomerang or running Reports. We apologize for any inconvenience this issue may cause and will post an update here shortly as we learn more.
Posted Jun 04, 2024 - 14:38 EDT
This incident affected: CRM and Reporting.