Partial service outage
Incident Report for Bloomerang
Resolved
This incident has been resolved, and functionality restored.
Posted Jan 30, 2024 - 09:19 EST
Identified
We’re currently experiencing degraded performance issues with one of our Integrations. Our team has identified the issue and is currently working to restore operations. We apologize for any inconvenience. Users may be affected. An update will be provided as information becomes available.
Posted Jan 29, 2024 - 18:13 EST
This incident affected: CRM and Integrations.