Support Chat is Temporarily Unavailable

Incident Report for Bloomerang

Resolved

Support chat has remained stable. Monitoring has completed, and this incident is now resolved.
Posted Jan 09, 2026 - 17:03 EST

Monitoring

At this time, support chat functionality has been restored. We will continue to monitor the situation to ensure continued stability. Thank you for your patience and understanding.
Posted Jan 09, 2026 - 16:00 EST

Identified

We are experiencing a service disruption with our support chat functionality. If you need assistance with any of our Bloomerang products, please reach out via email or phone. Contact information can be found at https://bloomerang.com/contact/customers/
Posted Jan 09, 2026 - 15:53 EST
This incident affected: Bloomerang CRM (CRM App - crm.bloomerang.co), Bloomerang Volunteer (Volunteer App - volunteer.bloomerang.co), Qgiv by Bloomerang (Fundraising App - secure.qgiv.com), and Chat Support.