We're experiencing an elevated level of errors and are currently looking into the issue.
Incident Report for Bloomerang
Resolved
This incident has been resolved. We have determined the root cause to be an unusually large number of particular requests. We have identified an architecture change we can make that will better handle the large number of requests and are beginning work on that immediately.
Posted Jul 22, 2020 - 14:35 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2020 - 14:05 EDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2020 - 13:59 EDT
This incident affected: CRM and API.