Error when opening some links in email using Chrome
Incident Report for Bloomerang
Resolved
This incident has been resolved.
Posted May 03, 2022 - 08:54 EDT
Investigating
We are receiving reports of an issue with links in emails throwing the error: "Your connection is not Private" when opened using Chrome browser. Our email service provider is aware and have identified the root cause and working on resolution.

For latest updates on the status of this issue, please see: https://status.sendgrid.com/
Posted May 02, 2022 - 21:16 EDT