Various Registration and Donation forms are not loading

Incident Report for Bloomerang

Resolved

The issue affecting various registration, and auction forms on Bloomerang Fundraising has been resolved, and all services are functioning normally. Thank you for your patience while our team worked to restore service.
Posted Aug 04, 2026 - 16:15 EDT

Identified

The issue has been identified, we are working to resolve it as quickly as possible
Posted Aug 04, 2026 - 14:08 EDT

Investigating

We're aware that some donation, registration, and auction forms on Bloomerang Fundraising aren't loading correctly, and some supporters may also be experiencing login issues. We're on it and working to restore service as quickly as possible.
Posted Aug 04, 2026 - 14:00 EDT
This incident affected: Qgiv by Bloomerang (Fundraising App - secure.qgiv.com).