Partial service outage

Incident Report for Bloomerang

Resolved

This issue has been resolved.
Posted Aug 19, 2026 - 13:29 EDT

Monitoring

Application performance looks stable. We are monitoring systems before resolving.
Posted Aug 19, 2026 - 13:01 EDT

Update

Performance has improved, but some users may still experience intermittent errors when navigating the application. Our team is actively working to restore performance for all users.
Posted Aug 19, 2026 - 12:53 EDT

Identified

We’re currently experiencing degraded performance issues with one or more of our listed components. Our team has identified the issue and is currently working to restore operations. We apologize for any inconvenience.
Posted Aug 19, 2026 - 12:02 EDT
This incident affected: Bloomerang CRM (CRM App - crm.bloomerang.co).