Billing Portal & User Creation Temporarily Unavailable
Incident Report for Bloomerang
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 14:00 EDT
Update
We are continuing to monitor & have identified additional impacts related to this issue. Any users created between 12 PM EDT and 4:30 PM EDT may have issues validating their user account. Users may resolve this by deleting and recreating the account now that this issue is fixed.
Posted Jul 16, 2024 - 17:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2024 - 16:09 EDT
Identified
The issue has been identified and Bloomerang is working with our Billing Partner to resolve the issue. Our team is currently working to restore functionalities. We apologize for any inconvenience, we will provide frequent updates as we learn more.
Posted Jul 16, 2024 - 13:56 EDT
Investigating
Our team is currently investigating an issue with the Billing Portal not loading for some customers. If you need to manage your invoice or subscription, please email billing@bloomerang.com until this is resolved.
Posted Jul 16, 2024 - 13:04 EDT
This incident affected: CRM.