Partial service outage - Email Templates

Incident Report for Bloomerang

Resolved

We've continued monitoring this issue and confirmed that functionality has been restored. We appreciate your patience while we worked to resolve this issue.
Posted Mar 10, 2025 - 13:13 EDT

Monitoring

We have confirmed that a fix for this issue has been implemented and our team is continuing to communicate with our integration partner to ensure performance is restored. We will provide updates as we learn more.
Posted Mar 10, 2025 - 12:32 EDT

Identified

We have confirmed this issue is due to an incident with an integration partner. Users may experience issues editing email templates, however, email sending functionality remains unaffected.

Our team is communicating with our integration partner to diagnose and resolve the issue. We will provide updates as we learn more.
Posted Mar 10, 2025 - 12:06 EDT

Investigating

We’re currently experiencing degraded performance issues with loading or editing Email Templates.

Our team is investigating the issue and is currently working to restore operations. We apologize for any inconvenience. Users may be affected. An update will be provided within 30 minutes.
Posted Mar 10, 2025 - 11:29 EDT
This incident affected: Bloomerang CRM (CRM - Email Service, CRM Email Templates).