Partial service outage for Forms

Incident Report for Bloomerang

Resolved

We have monitored this issue thought out the afternoon and confirmed we have restored full functionality across CRM systems. We appreciate your patience while we worked to resolve this issue.
Posted May 15, 2025 - 19:00 EDT

Monitoring

We have tested and reviewed the results, the issue appears to be resolved at this time.

We will continue to monitor for the remainder of the day, to ensure all functionality is restored.
Posted May 15, 2025 - 15:25 EDT

Update

We have completed the implementation process to resolve the degraded performance issues affecting CRM systems.
We are reviewing the results and will provide additional updates once we confirm this has solved the issue.
Posted May 15, 2025 - 14:43 EDT

Update

We have begun the implementation process to resolve the degraded performance issues affecting CRM systems. We will provide additional updates once the implementation has been completed.
Posted May 15, 2025 - 13:50 EDT

Update

We are planning to implement a fix for this issue between 1:45-3:45pm ET; during this timeframe customers may experience brief interruptions in the use of CRM services. We will provide an update once the implementation process has started and once completed.
Posted May 15, 2025 - 13:40 EDT

Update

We've identified the need to implement a change across CRM systems that will require a momentary interruption in CRM services (this will not affect Bloomerang Volunteer nor Qgiv by Bloomerang). Once we've determined the timeframe for the change, we'll provide another update noting a maintenance window.
Posted May 15, 2025 - 12:49 EDT

Identified

Our team has identified the cause and we are working to restore operations. Users will continue to encounter issues when attempting to submit and validate forms using CAPTCHA and may encounter brief service interruptions as we work on issue resolution. We apologize for any inconvenience and an update will be provided within 15 minutes.
Posted May 15, 2025 - 12:07 EDT

Investigating

We’re currently experiencing degraded performance issues for Bloomerang forms and CAPTCHA validation. Our team actively investigating the issue and is currently working to restore operations. We apologize for any inconvenience. Users may be affected. An update will be provided within 30 minutes.
Posted May 15, 2025 - 11:35 EDT
This incident affected: Bloomerang CRM (CRM App - crm.bloomerang.co).