Degraded Performance

Incident Report for Bloomerang

Resolved

This incident has been resolved.
Posted Oct 14, 2024 - 18:29 EDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Oct 14, 2024 - 18:22 EDT

Investigating

We are currently investigating reports of degraded performance involving slowness starting around 5:45pm EDT. We apologize for any inconvenience this issue may cause and will post an update here shortly as we learn more.
Posted Oct 14, 2024 - 18:19 EDT
This incident affected: Bloomerang CRM (CRM App - crm.bloomerang.co).