Users unable to login

Incident Report for Bloomerang

Resolved

Earlier today, between approximately 8:35 AM and 9:49 AM ET, some Bloomerang Fundraising users experienced difficulty logging in to the platform.

Our team identified that an internal caching service reached capacity, which prevented login requests from being processed successfully. To restore access, we cleared the affected cache, which resolved the issue. As a result, some users may have been prompted to log in again.

The underlying cause has been identified and our engineering team is actively working on a permanent fix to prevent recurrence. We will continue to closely monitor the system throughout the day.

We apologize for the inconvenience and appreciate your patience.
Posted Mar 10, 2026 - 10:07 EDT

Investigating

We are currently investigating an issue impacting Bloomerang Fundraising users’ ability to log in to the platform.
Posted Mar 10, 2026 - 08:55 EDT
This incident affected: Qgiv by Bloomerang (Fundraising App - secure.qgiv.com).