Mailchimp Performance Degradation
Incident Report for Bloomerang
Resolved
Upon further investigation we have found that the impact of this issue was limited. If you are experiencing issues while Connecting to or Disconnecting from the MailChimp integration, please email support@bloomerang.com.
Posted Mar 29, 2024 - 17:33 EDT
Investigating
We are currently experiencing degraded performance issues with our MailChimp integration. These issues specifically occur while trying to Connect or Disconnect from the integration.

Our team has identified the issue and is currently working to restore operations. We apologize for any performance degradation customers may experience and will provide an update as soon as more information becomes available.
Posted Mar 28, 2024 - 17:09 EDT
This incident affected: CRM and Integrations.