Partial service outage

Incident Report for Bloomerang

Resolved

We've continued monitoring this morning and confirmed we restored full functionality to all affected Search and Constituent features. We appreciate your patience while we worked to resolve this issue.
Posted Feb 27, 2025 - 09:37 EST

Monitoring

A resolution has been reached with our hosting provider. Constituent search, Constituent Dashboard, and Constituent updates are functioning as expected now. Our teams will continue to monitor the application for any further issues.
Posted Feb 27, 2025 - 01:00 EST

Update

We will continue to monitor this issue with our hosting provider throughout the night. Users may encounter intermittent issues when attempting to search for Constituents or when loading the Constituents page. We will provide an update tomorrow morning, or until a resolution has been reached with our hosting provider.
Posted Feb 27, 2025 - 00:10 EST

Update

We are actively working with our hosting provider to restore service. Users may continue to encounter intermittent issues when attempting to search for Constituents or when loading the Constituents page. We will provide an update as more information becomes available.
Posted Feb 26, 2025 - 21:52 EST

Update

We are continuing to work with our hosting provider to restore service. Users may continue to encounter intermittent issues when attempting to search for Constituents or when loading the Constituents page. We will provide an update as more information becomes available.
Posted Feb 26, 2025 - 20:55 EST

Identified

We have identified there is an issue with our hosting provider and we are working with them to resolve it. Users may continue to encounter intermittent issues when attempting to search for Constituents or when loading the Constituents page. We will provide another update in 15 minutes as we learn more from our provider.
Posted Feb 26, 2025 - 20:33 EST

Investigating

We're currently experiencing degraded performance issues with the ability to search for Constituents, as well as loading the Constituent homepage, and updating Constituents.

Our team is investigating the issue and is currently working to restore operations. We apologize for any inconvenience. Users may be affected. An update will be provided within 30 minutes.
Posted Feb 26, 2025 - 19:57 EST
This incident affected: Bloomerang CRM (CRM Search, CRM API - api.bloomerang.co, CRM App - crm.bloomerang.co).