Degraded Performance while viewing Reports & Email Previews
Incident Report for Bloomerang
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 18:09 EDT
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted Jun 03, 2024 - 11:01 EDT
Investigating
We are currently investigating reports of degraded performance involving slowness while viewing Reports or Email Previews. We apologize for any inconvenience this issue may cause and will post an update here shortly as we learn more.
Posted Jun 03, 2024 - 10:55 EDT
This incident affected: CRM, Email Templates, and Reporting.