Partial Outage with our DonorSearch Integration Service
Incident Report for Bloomerang
Resolved
Services with our DonorSearch Integration have been restored and this issue has been resolved.
Posted Nov 20, 2023 - 13:41 EST
Identified
We’re currently experiencing degraded performance issues with our DonorSearch Integration. Our team is investigating this issue and is currently working to restore operations.

We apologize for any inconvenience. Users may be affected. An update will be provided within 30 minutes.
Posted Nov 20, 2023 - 12:24 EST
This incident affected: CRM and Integrations.