Monitoring confirmed performance is restored and this incident is resolved. We apologize for any inconvenience.
Posted Oct 30, 2024 - 22:32 EDT
Monitoring
We have identified the issue and implemented a fix. Performance is now restored and we are continuing to monitor to confirm.
Posted Oct 30, 2024 - 22:16 EDT
Update
Some error pages may be occurring for users attempting to log in or add constituent and transaction data. Issues are intermittent and may be resolved by refreshing the browser and trying again. We continue investigating this issue and will provide another update within 30 minutes.
Posted Oct 30, 2024 - 21:35 EDT
Investigating
We are currently investigating reports of Intermittent degraded performance across Bloomerang, these issues may be impacting multiple areas of the application. We apologize for any inconvenience this issue may cause and will provide an update in approximately 30 minutes as we learn more.